| config SUNRPC | |
| tristate | |
| config SUNRPC_GSS | |
| tristate | |
| config SUNRPC_XPRT_RDMA | |
| tristate | |
| depends on SUNRPC && INFINIBAND && EXPERIMENTAL | |
| default SUNRPC && INFINIBAND | |
| help | |
| This option allows the NFS client and server to support | |
| an RDMA-enabled transport. | |
| To compile RPC client RDMA transport support as a module, | |
| choose M here: the module will be called xprtrdma. | |
| If unsure, say N. | |
| config SUNRPC_REGISTER_V4 | |
| bool "Register local RPC services via rpcbind v4 (EXPERIMENTAL)" | |
| depends on SUNRPC && EXPERIMENTAL | |
| default n | |
| help | |
| Sun added support for registering RPC services at an IPv6 | |
| address by creating two new versions of the rpcbind protocol | |
| (RFC 1833). | |
| This option enables support in the kernel RPC server for | |
| registering kernel RPC services via version 4 of the rpcbind | |
| protocol. If you enable this option, you must run a portmapper | |
| daemon that supports rpcbind protocol version 4. | |
| Serving NFS over IPv6 from knfsd (the kernel's NFS server) | |
| requires that you enable this option and use a portmapper that | |
| supports rpcbind version 4. | |
| If unsure, say N to get traditional behavior (register kernel | |
| RPC services using only rpcbind version 2). Distributions | |
| using the legacy Linux portmapper daemon must say N here. | |
| config RPCSEC_GSS_KRB5 | |
| tristate "Secure RPC: Kerberos V mechanism (EXPERIMENTAL)" | |
| depends on SUNRPC && EXPERIMENTAL | |
| select SUNRPC_GSS | |
| select CRYPTO | |
| select CRYPTO_MD5 | |
| select CRYPTO_DES | |
| select CRYPTO_CBC | |
| help | |
| Choose Y here to enable Secure RPC using the Kerberos version 5 | |
| GSS-API mechanism (RFC 1964). | |
| Secure RPC calls with Kerberos require an auxiliary user-space | |
| daemon which may be found in the Linux nfs-utils package | |
| available from http://linux-nfs.org/. In addition, user-space | |
| Kerberos support should be installed. | |
| If unsure, say N. | |
| config RPCSEC_GSS_SPKM3 | |
| tristate "Secure RPC: SPKM3 mechanism (EXPERIMENTAL)" | |
| depends on SUNRPC && EXPERIMENTAL | |
| select SUNRPC_GSS | |
| select CRYPTO | |
| select CRYPTO_MD5 | |
| select CRYPTO_DES | |
| select CRYPTO_CAST5 | |
| select CRYPTO_CBC | |
| help | |
| Choose Y here to enable Secure RPC using the SPKM3 public key | |
| GSS-API mechansim (RFC 2025). | |
| Secure RPC calls with SPKM3 require an auxiliary userspace | |
| daemon which may be found in the Linux nfs-utils package | |
| available from http://linux-nfs.org/. | |
| If unsure, say N. |